May I ask whether this compilation is correct? The content on the document is really too little

Viewed 99

May I ask whether this compilation is correct? The content on the document is really too little.

/data/plugins # answer build --with github.com/apache/incubator-answer-plugins/user-center-wecom
try to build a new answer with plugins:
github.com/apache/incubator-answer-plugins/user-center-wecom
[build] tmp dir: /data/plugins/answer_build2265689471
[go mod tidy]
go: finding module for package github.com/apache/incubator-answer/cmd
go: finding module for package github.com/apache/incubator-answer-plugins/user-center-wecom
go: downloading github.com/apache/incubator-answer-plugins/user-center-wecom v1.2.5
go: downloading github.com/apache/incubator-answer-plugins v1.2.1
go: found github.com/apache/incubator-answer-plugins/user-center-wecom in github.com/apache/incubator-answer-plugins/user-center-wecom v1.2.5
go: found github.com/apache/incubator-answer/cmd in github.com/apache/incubator-answer v1.2.5
go: downloading github.com/imroc/req/v3 v3.33.1
go: downloading github.com/silenceper/wechat/v2 v2.1.6
go: downloading github.com/hashicorp/go-multierror v1.1.1
go: downloading github.com/quic-go/qpack v0.4.0
go: downloading github.com/quic-go/quic-go v0.32.0
go: downloading github.com/go-redis/redis/v8 v8.11.5
go: downloading github.com/bradfitz/gomemcache v0.0.0-20220106215444-fb4bf637b56d
go: downloading github.com/hashicorp/errwrap v1.1.0
go: downloading github.com/onsi/ginkgo/v2 v2.2.0
go: downloading github.com/cespare/xxhash/v2 v2.2.0
go: downloading github.com/dgryski/go-rendezvous v0.0.0-20200823014737-9f7001d12a5f
go: downloading golang.org/x/exp v0.0.0-20221205204356-47842c84f3db
go: downloading github.com/quic-go/qtls-go1-18 v0.2.0
go: downloading github.com/quic-go/qtls-go1-19 v0.2.0
go: downloading github.com/quic-go/qtls-go1-20 v0.1.0
go: downloading github.com/go-task/slim-sprig v0.0.0-20210107165309-348f09dbbbc0
go: downloading github.com/alicebob/miniredis/v2 v2.30.0
go: downloading github.com/alicebob/gopher-json v0.0.0-20200520072559-a9ecdc9d1d3a
go: downloading gopkg.in/h2non/gock.v1 v1.1.2
go: downloading github.com/yuin/gopher-lua v0.0.0-20220504180219-658193537a64
go: downloading github.com/onsi/ginkgo v1.16.5
go: downloading github.com/onsi/gomega v1.20.1
go: downloading github.com/h2non/parth v0.0.0-20190131123155-b4df798d6542
go: downloading github.com/nxadm/tail v1.4.8
go: downloading github.com/golang/protobuf v1.5.2
[go mod vendor]
2 Answers

As far as I can tell from the logs now, everything is fine.

image.png

go: finding module for package github.com/apache/incubator-answer/cmd
go: finding module for package github.com/apache/incubator-answer-plugins/user-center-wecom
go: found github.com/apache/incubator-answer-plugins/user-center-wecom in github.com/apache/incubator-answer-plugins/user-center-wecom v1.2.5
go: found github.com/apache/incubator-answer/cmd in github.com/apache/incubator-answer v1.2.5
[go mod vendor]
[go list -mod=mod -m -f {{.Dir}} github.com/apache/incubator-answer]
build failed failed to copy ui files: failed to open source file build\favicon.ico: stat build\favicon.ico: invalid argument

Why can't you get around this mistake