Instructions fail, as config.yaml doesn't exist, what am I missing?

Viewed 139

Hi,
Following instructions on how to install Answer, I always, always get to this:

read config failed:  stat /data/conf/config.yaml: no such file or directory
config file path:  /data/conf/config.yaml
Answer is starting..........................
panic: stat /data/conf/config.yaml: no such file or directory

Volumes are created, i18n and upload folders are created, conf is NOT created, serverIP:9080:/install is NOT reachable, therefore the instructions on the site, when followed, do not leat to a working installation. What am I missing? I cannot get to the interface that creates the config file, as per the instructions.

Thanks.
(tested with 1.2.1 and 1.2.0, same thing, either docker or docker compose)

2 Answers

I using the 1.2.0 version to test it. It looks well. You can check my commands below to see if there is something wrong somewhere.

image.png

Just a note of remind, please make sure your environment is clean before you install it.

docker rm -f answer
docker volume rm answer-data

Thank you, @LinkinStar.
Must have been something with my environment. It was clean from answer related files, however your example above still produced the same error. I created a new container for answer (I'm running docker inside LXD), deployed a fresh docker environment, followed your steps, and now it works.